Problems with Arduino Clones not Programming

Post Reply
User avatar
p.erasmus
Posts: 333
http://meble-kuchenne.info.pl
Joined: Thu Dec 03, 2020 12:01 pm
Location: Russia / Россия
Has thanked: 93 times
Been thanked: 65 times

Problems with Arduino Clones not Programming

Post by p.erasmus »

Hi All ,

Just a few things noticed when working with various clones (Arduino's) in Flowcode

1) It does not program from FC always a baud rate error
2) Some do program but the timings are way off (can see this running a 1 second Blink led Program)
3) sometimes they will only program from FC if you reboot(reset) them during FC trying to connect

Program them from the Arduino IDE they work well no baud rate errors and no timing problems and I assume the reason is that most off these close are supplied with a Hardware file that needs to be placed in the Arduino IDE in the Hardware folder,this the IDE know the peculiar settings this boards have.I have tried to re flash the Boot loader on a few a the ones that has a genuine ATMEL chip on and yields the correct device checksum program and after wards work perfectly in Flowcode the ones with clone chips (example WAVGAT) yields a wrong chip checksum) and I could not flash the Arduino boot loader and they do not work in FC.

Checking the WAVGAT board device file the boot loader is set for 57600 bit/sec , and as it is a clone chip I could not flash the Arduino Boot loader due to the chip checksum error picked up by the IDE.

My take on this is the issue people having to connect to Flowcode is not because of Flowcode it because of the peculiar Boot loaders these clone chip have and it not possible to cure them with the correct Boot loader due to the Chip checksum, the ones with the ATMEL chip I could flash the boot loader and they are working just as the Original ARDUINO boards.

I fall short of understanding the device files totally for the Arduino IDE so I will not say that it not possible at all to cure them by changing some things in these files all I am saying is people should stop to blame FC if the clones cannot connect to AvrDude in FC

:D :D :D :D
Regards Peter - QME Electronics

Post Reply