BMP280 wrong setting SDA and SCL for arduino in V9.2

rzeszurzeszu
Posts: 22
http://meble-kuchenne.info.pl
Joined: Fri Aug 27, 2021 1:34 pm
Been thanked: 2 times

BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by rzeszurzeszu »

Hi, how can I change ports? They are highlighted in grey by default , but they are wrong defined .. PORTC3 and PORTC4 instead of PORTC4 and PORTC5

medelec35
Matrix Staff
Posts: 1326
Joined: Wed Dec 02, 2020 11:07 pm
Has thanked: 471 times
Been thanked: 425 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by medelec35 »

Hi, rzeszurzeszu.
Thank you for letting us know.
I have fixed the issue and the BMP280 has now been pushed onto the update system.
Can you let us know how you get on, please?
Martin

rzeszurzeszu
Posts: 22
Joined: Fri Aug 27, 2021 1:34 pm
Been thanked: 2 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by rzeszurzeszu »

Hello
thank you for update.
FYI : communication works but I get 0 for temp and value 0 for pressure, so something is not correct with this component. This sensor works correctlyIn Flowcode 8.2 .
Additionally this sensor (BMP280) has no humidity element, it has only pressure and temperature.
Humidity is in BME280
Working of sensor is confirmed using Arduino IDE.

Best Regards,

medelec35
Matrix Staff
Posts: 1326
Joined: Wed Dec 02, 2020 11:07 pm
Has thanked: 471 times
Been thanked: 425 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by medelec35 »

I have a BME280 Module & the BMP280 component working is for me.
I can see the correct Pressure and Temperature.
Martin

rzeszurzeszu
Posts: 22
Joined: Fri Aug 27, 2021 1:34 pm
Been thanked: 2 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by rzeszurzeszu »

Hello,
I can confirm that using device BMP280 we got zero (0) as output.
Is there someone else how could check ?
Using BME280 COmponent I get "stange" ASCII signs as output

medelec35
Matrix Staff
Posts: 1326
Joined: Wed Dec 02, 2020 11:07 pm
Has thanked: 471 times
Been thanked: 425 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by medelec35 »

Can you post your flowchart so I can try it with my UNO and Redboard?
Martin

rzeszurzeszu
Posts: 22
Joined: Fri Aug 27, 2021 1:34 pm
Been thanked: 2 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by rzeszurzeszu »

Hello,
here you are.

Thank you for help in advance
Attachments
output.PNG
output.PNG (12.98 KiB) Viewed 3872 times
Flowcode1.fcfx
(12.55 KiB) Downloaded 141 times

medelec35
Matrix Staff
Posts: 1326
Joined: Wed Dec 02, 2020 11:07 pm
Has thanked: 471 times
Been thanked: 425 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by medelec35 »

Your flowchart is working for me:
Pressure & Temp.png
Pressure & Temp.png (16.35 KiB) Viewed 3864 times
Can you try the attached sniffer, my results for the BME shows:
Sniffer - BMP280.png
Sniffer - BMP280.png (1.95 KiB) Viewed 3864 times
Perhaps the Ardunio is not seeing your device, or the address is incorrect?
Attachments
IC2 Address Sniffer Ardunio UNO.fcfx
(21.29 KiB) Downloaded 141 times
Martin

rzeszurzeszu
Posts: 22
Joined: Fri Aug 27, 2021 1:34 pm
Been thanked: 2 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by rzeszurzeszu »

Hello,
Port is detected, but the output is still 0 from sensor.

I just tested it using sample code for IDE and it works ... so sensor is OK.
I have found something strange, If i click in gray area on Panel I got information like attached, SDA and SCL are still wrong (D3 and D4)... but in HX711 properties are correct (D4 and D5)

Do you have more idea what could be wrong ?

BR,
mateusz
Attachments
output3.PNG
output3.PNG (90.52 KiB) Viewed 3832 times
output2.PNG
output2.PNG (38.56 KiB) Viewed 3846 times
output1.PNG
output1.PNG (8.65 KiB) Viewed 3846 times

rzeszurzeszu
Posts: 22
Joined: Fri Aug 27, 2021 1:34 pm
Been thanked: 2 times

Re: BMP280 wrong setting SDA and SCL for arduino in V9.2

Post by rzeszurzeszu »

Hello,
still no update or idea how to treat it?


BR,

Post Reply